Run-Down Forums Forum Index Run-Down Forums

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Run-Down Forums Forum Index
Open Mic Night
Nothing to do with Running
Post new topic   Reply to topic

Goto page 1, 2, 3  Next
Post new topic   Reply to topic    Run-Down Forums Forum Index -> Open Mic Night
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Fri Sep 10, 1999 6:22 am    Post subject: Reply with quote

This has nothing to do with Running.
I come here from following your profile from the Discus Demo forum. I have been sitting here admiring how you format the Nav bar so the folders move to the right when they go down.
If you don't consider it a "trade secret" then I'd appreciate very much if you can please share it on how you did it.

[Anonymously Posted by: 'Nguyen']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Fri Sep 10, 1999 7:29 am    Post subject: Reply with quote

Hi Nguyen,

Thanks for the compliments. Smile I'd be happy to share how I set it up, but I don't have the files handy right now. I should be able to post something this evening.

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Guest






PostPosted: Fri Sep 10, 1999 6:45 pm    Post subject: Reply with quote

That'd be great. Thank you in advance.

[Anonymously Posted by: 'nguyen']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Fri Sep 10, 1999 8:00 pm    Post subject: Reply with quote

I haven't forgotten about you, just busy moving to a new computer... #%@! tape backup systems!!!

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Sat Sep 11, 1999 8:03 am    Post subject: Reply with quote

Ok Nguyen, I've moved my files (hopefully all of them) to the new computer and reinstalled ftp, so...

Rather than try to work within the constraints of Discus formatting, I've posted a text file here. It should cover all the changes regarding the nav bar, plus some superflous info in between. Let me know if you have any problems accessing it.

Dan

p.s. Keep in mind that I'm running version 5 of the 3.1 beta, so some line numbers may have changed.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Guest






PostPosted: Tue Sep 21, 1999 7:31 pm    Post subject: Reply with quote

Hello,

I haven't tried your code yet. I am sorry I didn't come back to say thank you earlier. Lately I am having too much problem with this beta. I shouldn't have installed the beta, but oh well ...

I just want to say thank you though.
I appreciate it!

btw,.. how did you get your beta to work so fine? did it not give you any trouble at all? hum...???

[Anonymously Posted by: 'nguyen']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Wed Sep 22, 1999 3:59 am    Post subject: Reply with quote

Hi Nguyen,

Not a problem; I could tell from the Discus forum that you were having some problems. Sorry to hear that.

I'm not quite sure why it works so well for me. The only real problem I've had was with re-indexing. It corrupted a few files, but I had them backed up, so it wasn't a problem. I think the key is that this board is pretty small. Most of the reported problems are on boards with 30,000+ messages.

Now you see why I stuck with v5 once I got it working... Wink

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Thu Dec 02, 1999 7:09 am    Post subject: Reply with quote

As I've been receiving several requests for the code/.conf file changes, I am posting them for everyone to see! Each link will launch a new window to the text file version of the changes. I will put together a zip file shortly of all the files.

Here are the .conf template files:

topics.conf

subtopics.conf

newpage.conf

messages.conf

addmessage-public.conf

addmessage-private.conf

And here are the mods for the navigation bar at the top of the page:

Navigation bar mods

Hopefully I didn't miss anything.

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Guest






PostPosted: Thu Dec 02, 1999 7:45 am    Post subject: Reply with quote

Dan,

I already sent you an email but I also wanted to thank you publicly. You've done a great job with your board as shown by the number of people who want to copy it. Smile

I thank you again for sharing your skills and helping the rest of us have as nice a board as you do.

-Mark

[Anonymously Posted by: 'Mark']
Back to top
Guest






PostPosted: Thu Dec 02, 1999 11:13 am    Post subject: Reply with quote

Ditto!!!!

[Anonymously Posted by: 'Ed']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Thu Dec 02, 1999 11:19 am    Post subject: Reply with quote

Thanks guys! Smile

Let me know how you like v14.

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Guest






PostPosted: Thu Dec 02, 1999 1:26 pm    Post subject: Reply with quote

I modified my files with your navigation bar mods and it works great!!! Can't thank you enough. V14 seems to work well so far. Just a few test messages so it's not a good scale test. Everything I have tried seems to work well except the e-mail notification. The test says it sends the message but nothing is recieved. This worked for me in 3.0 and I am configuring it the same way. Don't know - I will check Kevin's site to see if anyone else is reporting this.

Now I will take a look at the .conf files you posted. I was most interested in the nav bar. A very clean look.

I need the pro version for the self registration feature. I wonder when that will be available in 3.1

Thanks again for your generous help!

[Anonymously Posted by: 'Ed']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Thu Dec 02, 1999 2:08 pm    Post subject: Reply with quote

Hi Ed,

Actuallly, if you look over to the left of this board, you will see "New Account." I carried over the User self-registration setup that I used on v3.0. Although, at this point I have no idea what I did to accomplish that... The pro version would be nice for the editing and archiving features, though.

If you don't have any luck figuring out the email notification, I'll check my setup. I seem to remember it not working until I changed a few settings in a way that seemed reversed. Are you sending the messages from a non-admin sign-in? That could possibly be the problem. I don't believe it's cookie based recognition, but I could be wrong.

Glad to hear it's worked well so far.

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Guest






PostPosted: Thu Dec 02, 1999 5:17 pm    Post subject: Reply with quote

Dan - I can't get the mail to go from the test button in Options - configure e-mail notification section. As I said, I get a page saying that the message was successfully sent but it never shows up. I thought it might be my e-mail problem but I had it sent to my corporate account and I didn't get it there either. I am on an NT server using blat as the mail program. I set up according to the instructions I got with 3.0.

Getting the self registation feature incorporated into the beta from 3.0 pro is good work! Looks like you have a good grip on perl scripts.

Take care

[Anonymously Posted by: 'Ed']
Back to top
Dan
Chief Pontificator
Chief Pontificator


Joined: 22 Mar 1999
Posts: 9334
Location: Salem, OR

PostPosted: Thu Dec 02, 1999 8:46 pm    Post subject: Reply with quote

I had a problem with the email test not working. It said it was ok, but the test message never showed up. I don't get email notification when I post to this board, but I do when anyone else posts (except your last message...). That's why I alluded to testing through a different user name. If you give me the URL of your board, I can check it out on the off chance that it recognizes users through cookies.

I'm not too familiar with NT servers (I don't think I mentioned that in my list of inferior Windows web products Wink ), so I can't provide much help with that aspect.

As far as self-registration and perl modifying, I believe I added that in to my 3.0 installation through suggestions I found in the Discus help forum. I don't think there was much more to it than creating a link to the correct part of the script, as I don't remember having to do much different when I upgraded to 3.1.

I really don't have that much perl experience, especially with Discus. I've done a decent amount of work with scripts such as Gossamer Threads' Links and DBMan, UBB, and UltraBoard, but Discus is written in a way that I can hardly decipher, let alone safely modify! Most of my changes have been cosmetic (the only area it really lacks, in my opinion).

Dan
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Run-Down Forums Forum Index -> Open Mic Night All times are GMT - 8 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group